Kit Kat2There have been widespread reports that the latest update for Android (version 4.4 also known as Kit-Kat) is causing Exchange ActiveSync connectivity issues. The problems vary from not being able to authenticate to the server when setting up an Exchange account to synchronization stopping for ActiveSync accounts that are already on the device. A thread on the Android issue tracking site about this problem has been closed and there is a statement that the issue will be addressed in a future release of Android. No further details have been given as to when this fix will be made available.

At this time, it would seem that the best option would be to bypass upgrading to Kit-Kat until the patch is rolled out. However, if you are one of the unfortunate people that have already applied the update, reverting back to the previous version is not an easy task and is not recommended for most users. As an option, there are numerous apps that are available that can be used to access your Exchange account. Some of the more popular client apps are:

Touchdown for Exchange

RoadSync

Moxier Mail

The update has only been released to a small number of newer Android devices. The Nexus 4,5, and 7, the Google Play Editions of the HTC One and Samsung Galaxy S4, and the Motorola Moto X are part of this group. However, the phone manufacturers and wireless carriers are announcing that Kit-Kat will be made available for other models soon, so the number of devices that are affected will continue to grow until the patch is available for download.

More on this issue can be found here.

Have a thought on this article? Share it here.